Rabu, 02 Maret 2011

Sukses adalah sebuah perjalanan, bukan tujuan akhir

Success is a journey, not a destination.
~ Ben Sweetland
»»  READMORE...
Visi tanpa eksekusi adalah lamunan. Eksekusi tanpa visi adalah mimpi buruk.

Vision without execution is a daydream. Execution without vision is a nightmare.

~ Japanese Proverb
»»  READMORE...
Dalam kehidupan ini kita tidak dapat selalu melakukan hal yang besar. Tetapi kita dapat melakukan banyak hal kecil dengan cinta yang besar.

In this life we cannot always do great things. But we can do small things with great love

~Mother Teresa
»»  READMORE...
Jika Anda menginginkan sesuatu yang belum pernah anda miliki, Anda harus bersedia melakukan sesuatu yang belum pernah Anda lakukan.

If you want something you’ve never had, you must be willing to do something you’ve never done.

~ Thomas Jefferson
»»  READMORE...
Transmission Control Protocol/Internet Protocol
TCP/IP (singkatan dari Transmission Control Protocol/Internet Protocol) adalah standar komunikasi data yang digunakan oleh komunitas internet dalam proses tukar-menukar data dari satu komputer ke komputer lain di dalam jaringan Internet.

Setiap lapisan yang dimiliki oleh kumpulan protokol (protocol suite) TCP/IP diasosiasikan dengan protokolnya masing-masing. Protokol utama dalam protokol TCP/IP adalah sebagai berikut:
• Protokol lapisan aplikasi: bertanggung jawab untuk menyediakan akses kepada aplikasi terhadap layanan jaringan TCP/IP. Protokol ini mencakup protokol Dynamic Host Configuration Protocol (DHCP), Domain Name System (DNS), Hypertext Transfer Protocol (HTTP), File Transfer Protocol (FTP), Telnet, Simple Mail Transfer Protocol (SMTP), Simple Network Management Protocol (SNMP), dan masih banyak protokol lainnya. Dalam beberapa implementasi stack protokol, seperti halnya Microsoft TCP/IP, protokol-protokol lapisan aplikasi berinteraksi dengan menggunakan antarmuka Windows Sockets (Winsock) atau NetBIOS over TCP/IP (NetBT).
• Protokol lapisan antar-host: berguna untuk membuat komunikasi menggunakan sesi koneksi yang bersifat connection-oriented atau broadcast yang bersifat connectionless. Protokol dalam lapisan ini adalah Transmission Control Protocol (TCP) dan User Datagram Protocol (UDP).
• Protokol lapisan internetwork: bertanggung jawab untuk melakukan pemetaan (routing) dan enkapsulasi paket-paket data jaringan menjadi paket-paket IP. Protokol yang bekerja dalam lapisan ini adalah Internet Protocol (IP), Address Resolution Protocol (ARP), Internet Control Message Protocol (ICMP), dan Internet Group Management Protocol (IGMP).
• Protokol lapisan antarmuka jaringan: bertanggung jawab untuk meletakkan frame-frame jaringan di atas media jaringan yang digunakan. TCP/IP dapat bekerja dengan banyak teknologi transport, mulai dari teknologi transport dalam LAN (seperti halnya Ethernet dan Token Ring), MAN dan WAN (seperti halnya dial-up modem yang berjalan di atas Public Switched Telephone Network (PSTN), Integrated Services Digital Network (ISDN), serta Asynchronous Transfer Mode (ATM)).
Layanan
Berikut ini adalah layanan tradisional yang dapat berjalan di atas protokol TCP/IP:
• Pengiriman berkas (file transfer). File Transfer Protocol (FTP) memungkinkan pengguna komputer yang satu untuk dapat mengirim ataupun menerima berkas ke sebuah host di dalam jaringan. Metode otentikasi yang digunakannya adalah penggunaan nama pengguna (user name) dan [[password]], meskipun banyak juga FTP yang dapat diakses secara anonim (anonymous), alias tidak berpassword. (Keterangan lebih lanjut mengenai FTP dapat dilihat pada RFC 959.)
• Remote login. Network terminal Protocol (telnet) memungkinkan pengguna komputer dapat melakukan log in ke dalam suatu komputer di dalam suatu jaringan secara jarak jauh. Jadi hal ini berarti bahwa pengguna menggunakan komputernya sebagai perpanjangan tangan dari komputer jaringan tersebut. (Keterangan lebih lanjut mengenai Telnet dapat dilihat pada RFC 854 dan RFC 855.)
• Computer mail. Digunakan untuk menerapkan sistem surat elektronik. (Keterangan lebih lanjut mengenai e-mail dapat dilihat pada RFC 821 RFC 822.)
• Network File System (NFS). Pelayanan akses berkas-berkas yang dapat diakses dari jarak jauh yang memungkinkan klien-klien untuk mengakses berkas pada komputer jaringan, seolah-olah berkas tersebut disimpan secara lokal. (Keterangan lebih lanjut mengenai NFS dapat dilihat RFC 1001 dan RFC 1002.)
• Remote execution. Memungkinkan pengguna komputer untuk menjalankan suatu program tertentu di dalam komputer yang berbeda. Biasanya berguna jika pengguna menggunakan komputer yang terbatas, sedangkan ia memerlukan sumber yg banyak dalam suatu sistem komputer.
Ada beberapa jenis remote execution, ada yang berupa perintah-perintah dasar saja, yaitu yang dapat dijalankan dalam system komputer yang sama dan ada pula yg menggunakan sistem Remote Procedure Call (RPC), yang memungkinkan program untuk memanggil subrutin yang akan dijalankan di sistem komputer yg berbeda. (sebagai contoh dalam Berkeley UNIX ada perintah rsh dan rexec.)
• Name server yang berguna sebagai penyimpanan basis data nama host yang digunakan pada Internet (Keterangan lebih lanjut dapat dilihat pada RFC 822 dan RFC 823 yang menjelaskan mengenai penggunaan protokol name server yang bertujuan untuk menentukan nama host di Internet.)
»»  READMORE...
Pengertian Bandwidth
Bandwidth adalah luas atau lebar cakupan frekuensi yang digunakan oleh sinyal dalam medium transmisi.
Bandwidth dapat diartikan sebagai perbedaan antara komponen sinyal frekuensi tinggi dan sinyal frekuensi rendah. frekuensi sinyal diukur dalam satuan Hertz. sinyal suara tipikal mempunyai Bandwidth sekitar 3 kHz, analog TV broadcast (TV) mempunyai Bandwidth sekitar 6 MHz. Bandwidth diartikan juga sebagai takaran jarak frekuensi. Dalam bahasa mudahnya, adalah sebuah takaran lalu lintas data yang masuk dan yang keluar. Dalam dunia hosting, kita di berikan jatah Bandwidth setiap bulan tergantung seberapa dalam kita merogoh kocek. Habisnya Bandwidth ditentukan seberapa banyak kita mengupload atau mendownload. Makin banyak anda melakukan aktivitas upload, ditambah makin banyaknya pengunjung yang mengakses, maka makin berkurang jatah Bandwidth yang diberikan, Misalkan, www.namasitus.com.
Digital Bandwidth
Digital Bandwidth adalah jumlah atau volume data yang dapat dikirimkan melalui sebuah saluran komunikasi dalam satuan bits per second tanpa distorsi. Analog Bandwith
Analog Bandwidth
Sedangkan analog Bandwidth adalah perbedaan antara frekuensi terendah dengan frekuensi tertinggi dalam sebuah rentang frekuensi yang diukur dalam satuan Hertz (Hz) atau siklus per detik, yang menentukan berapa banyak informasi yang bisa ditransimisikan dalam satu saat.
Bandwidth Komputer
Bandwidth Komputer Di dalam jaringan Komputer, Bandwidth sering digunakan sebagai suatu sinonim untuk data transfer rate yaitu jumlah data yang dapat dibawa dari sebuah titik ke titik lain dalam jangka waktu tertentu (pada umumnya dalam detik). Jenis Bandwidth ini biasanya diukur dalam bps (bits per second).

Alokasi Bandwidth
Alokasi atau reservasi Bandwidth adalah sebuah proses menentukan jatah Bandwidth kepada pemakai dan aplikasi dalam sebuah jaringan.
Penggunaan Bandwidth untuk LAN bergantung pada tipe alat atau medium yang digunakan, umumnya semakin tinggi Bandwidth yang ditawarkan oleh sebuah alat atau medium, semakin tinggi pula nilai jualnya.
Sedangkan penggunaan Bandwidth untuk WAN bergantung dari kapasitas yang ditawarkan dari pihak ISP, perusahaan harus membeli Bandwidth dari ISP, dan semakin tinggi Bandwidth yang diinginkan, semakin tinggi pula harganya.
Video streaming dan Voice over IP ([[VoIP]]) adalah beberapa contoh penggunaan teknologi baru yang turut mengkonsumsi Bandwidth dalam jumlah besar.
»»  READMORE...
Pengertian Antivirus Dan Macam – Macam Antivirus
Antivirus adalah sebuah jenis perangkat lunak yang digunakan untuk mendeteksi dan menghapus virus komputer dari sistem komputer. Disebut juga Virus Protection Software. Aplikasi ini dapat menentukan apakah sebuah sistem komputer telah terinfeksi dengan sebuah virus atau tidak. Umumnya, perangkat lunak ini berjalan di latar belakang (background) dan melakukan pemindaian terhadap semua berkas yang diakses (dibuka, dimodifikasi, atau ketika disimpan). Sebagian besar antivirus bekerja dengan beberapa metode seperti di bawah ini:
• Pendeteksian dengan menggunakan basis data virus signature (virus signature database): Cara kerja antivirus ini merupakan pendekatan yang banyak digunakan oleh antivirus tradisional, yang mencari tanda-tanda dari keberadaan dari virus dengan menggunakan sebagian kecil dari kode virus yang telah dianalisis oleh vendor antivirus, dan telah dikatalogisasi sesuai dengan jenisnya, ukurannya, daya hancurnya dan beberapa kategori lainnya. Cara ini terbilang cepat dan dapat diandalkan untuk mendeteksi virus-virus yang telah dianalisis oleh vendor antivirus, tapi tidak dapat mendeteksi virus yang baru hingga basis data virus signature yang baru diinstalasikan ke dalam sistem. Basis data virus signature ini dapat diperoleh dari vendor antivirus dan umumnya dapat diperoleh secara gratis melalui download atau melalui berlangganan (subscription).
• Pendeteksian dengan melihat cara bagaimana virus bekerja: Cara kerja antivirus seperti ini merupakan pendekatan yang baru yang dipinjam dari teknologi yang diterapkan dalam Intrusion Detection System (IDS). Cara ini sering disebut juga sebagai Behavior-blocking detection. Cara ini menggunakan policy (kebijakan) yang harus diterapkan untuk mendeteksi keberadaan sebuah virus. Jika ada kelakuan perangkat lunak yang “tidak wajar” menurut policy yang diterapkan, seperti halnya perangkat lunak yang mencoba untuk mengakses address book untuk mengirimkan e-mail secara massal terhadap daftar e-mail yang berada di dalam address book tersebut (cara ini sering digunakan oleh virus untuk menularkan virus melalui e-mail), maka antivirus akan menghentikan proses yang dilakukan oleh perangkat lunak tersebut. Antivirus juga dapat mengisolasi kode-kode yang dicurigai sebagai virus hingga administrator menentukan apa yang akan dilakukan selanjutnya. Keuntungan dari cara ini adalah antivirus dapat mendeteksi adanya virus-virus baru yang belum dikenali oleh basis data virus signature. Kekurangannya, jelas karena antivirus memantau cara kerja perangkat lunak secara keseluruhan (bukan memantau berkas), maka seringnya antivirus membuat alarm palsu atau “False Alarm” (jika konfigurasi antivirus terlalu “keras”), atau bahkan mengizinkan virus untuk berkembangbiak di dalam sistem (jika konfigurasi antivirus terlalu “lunak”), terjadi false positive. Beberapa produsen menyebut teknik ini sebagai heuristic scanning.
Antivirus yang menggunakan behavior-blocking detection ini masih sedikit jumlahnya, tapi di masa yang akan datang, kemungkinan besar semua antivirus akan menggunakan cara ini. Beberapa antivirus juga menggunakan dua metode di atas secara sekaligus.
Tabel berikut berisi beberapa antivirus yang beredar di pasaran :
Produk Situs Web
eSafe http://www.aks.com
Avast
http://www.asw.cz

Anyware AntiVirus http://www.helpvirus.com
Ansav http://www.ansav.com/
AVG Anti-Virus http://www.grisoft.com
Quick Heal http://www.quickheal.com
Vexira Antivirus
http://www.centralcommand.com
Command AntiVirus
http://www.authentium.com/command/index.html
eTrust
http://www.ca.com/virusinfo/
waVe Antivirus
http://www.cyber.com

SpIDer Guard
http://www.dials.ru
NOD32
http://www.nod32.com
F-Prot Antivirus
http://www.f-prot.com
F-Secure Anti-virus
http://www.fsecure.com
RAV AntiVirus
http://www.rav.ro
AntiVir dan AntiVir Personal Edition
http://www.antivir.de
ViRobot, DataMedic, Live-Call
http://www.hauri.co.kr
WinProof dan ExcelProof
http://www.hiwire.com.sg
Die Klinik
http://www.ikarus-software.at
Kaspersky Anti-Virus (AVP)
http://www.kaspersky.com
VirusBUSTER II
http://www.leprechaun.com.au
email scanning services
http://www.messagelabs.com/viruseye/
eScan
http://www.microworldtechnologies.com
MKS Vir
http://www.mks.com.pl
McAfee Anti-Virus dan McAfee Virus Scan http://www.mcafee.com atau http://www.nai.com
InVircible AV
http://www.invircible.com
Norman Virus Control
http://www.norman.no
Panda AntiVirus dan NanoScan
http://www.pandasoftware.com
Per AntiVirus
http://www.persystems.com/antivir.htm
Protector Plus
http://www.pspl.com
VirusNet PC and VirusNet LAN
http://www.safe.net
BitDefender
http://www.bitdefender.com
Sophos Anti-Virus
http://www.sophos.com
Antigen for Microsoft Exchange
http://www.sybari.com
Norton Antivirus dan Symantec Antivirus Corporate Edition
http://www.symantec.com
Trend Virus Control System dan PC-Cilin http://www.trendmicro.com
VirusBuster
http://www.vbuster.hu
ClamAV http://www.clamav.org
PCMAV
-
Windows Live OneCare dan Microsoft ForeFont http://onecare.live.com
ZoneAlarm AntiVirus http://www.zonealarm.com/
BullGuard Antivirus http://www.bullguard.com/
»»  READMORE...